Top > blog > 2013-04-15 > Androidエミュレータが動かない

広告

Androidエミュレータが動かない

Eclipse + ADTでAndroidの開発環境を構築してみたけど、コンパイルまではうまく行くが、エミュレータを動かすと

lib64EGL_translator.so

でsegfault(セグメンテーションフォールト)が起こる。

どうも 64 bit版(amd64など)に依存するエラーらしい。

解決できていないが、実機で動かせば良いみたいなので、その方向に行こうと思うけど、それはそれでまた問題が出てきそうで、躊躇している。
でも、それができないと実機にプログラムをインストールできないのだけれど (^^;

それにしても、これ以外(例えばドライバ関連)にも64 bit版に依存するエラーは多いので、ハード関係でいろいろやろうと思っている人は32bit版にしておいたほうだ良さそう。
少なくとも64bit版で動いて32bit版で動かないというものはないと思う

Category: [Android][トラブル] - 15:40:11


広告

Reload   Diff   Front page List of pages Search Recent changes Backup Referer   Help   RSS of recent changes
Last-modified: Sun, 14 Apr 2013 20:40:11 HAST (2432d)